Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
common_errors [2019/04/12 16:30]
armchairguru
common_errors [2019/04/12 16:40] (current)
armchairguru
Line 27: Line 27:
   * [[common_errors#​error:​_-1013,​_filter_failure:​_min_notional|ERROR:​ -1013, Filter failure: MIN_NOTIONAL]]   * [[common_errors#​error:​_-1013,​_filter_failure:​_min_notional|ERROR:​ -1013, Filter failure: MIN_NOTIONAL]]
   * [[common_errors#​error:​_timestamp_for_this_request_was_1000ms_ahead_of_the_server'​s_time|ERROR:​ Timestamp for this request was 1000ms ahead of the server'​s time]]   * [[common_errors#​error:​_timestamp_for_this_request_was_1000ms_ahead_of_the_server'​s_time|ERROR:​ Timestamp for this request was 1000ms ahead of the server'​s time]]
-  * [[common_errors#​nonce_error-nonce_must_be_greater_than|NONCE ERROR-nonce must be greater than]] 
   * [[common_errors#​getting_a_constant_"​configuration_change_detected"​_message_on_log_or_console|constant "​Configuration Change Detected"​ message]]   * [[common_errors#​getting_a_constant_"​configuration_change_detected"​_message_on_log_or_console|constant "​Configuration Change Detected"​ message]]
   * [[common_errors#​Incorrect trailing value for GROW. Value should be between 0 and your exit value. Using DEFAULT instead|Incorrect trailing value for GROW]]   * [[common_errors#​Incorrect trailing value for GROW. Value should be between 0 and your exit value. Using DEFAULT instead|Incorrect trailing value for GROW]]
Line 253: Line 252:
  
 [[common_errors|TOP]] [[common_errors|TOP]]
 +
 ---- ----
- 
  
 ====Error: -1021, Timestamp for this request is outside of the recvWindow==== ====Error: -1021, Timestamp for this request is outside of the recvWindow====
Line 261: Line 260:
 <file java> <file java>
 Error Application - Please fix: trading_api_key (trading_apiKey for V1.x) — Error: -1021, Timestamp for this request is outside of the recvWindow Error Application - Please fix: trading_api_key (trading_apiKey for V1.x) — Error: -1021, Timestamp for this request is outside of the recvWindow
- 
 ERROR ProfitTrailerService - completeBalances - nl.komtek.pt.utils.i:​ ERROR: -1021, Timestamp for this request is outside of the recvWindow ERROR ProfitTrailerService - completeBalances - nl.komtek.pt.utils.i:​ ERROR: -1021, Timestamp for this request is outside of the recvWindow
 </​file>​ </​file>​
Line 287: Line 285:
  
 [[common_errors|TOP]] [[common_errors|TOP]]
 +
 ---- ----
  
Line 301: Line 300:
  
 [[common_errors|TOP]] [[common_errors|TOP]]
 +
 ---- ----
  
 ====ERROR Application - Please install java 8==== ====ERROR Application - Please install java 8====
  
-If you get the above error, you need to install the proper version of the JAVA JDK. Version 9 is not supported, you will need to revert back to version 8. You will need to uninstall the current version first.+If you get the above error, you need to install the proper version of JAVA. Version 9, 10, or 11 are not supported, you will need to revert back to version 8. You will need to uninstall the current version first.
  
-This webpage contains the proper ​version: https://​www.oracle.com/technetwork/java/​javase/​downloads/​jdk8-downloads-2133151.html+This webpage contains the proper ​versions: https://​www.java.com/en/
  
 This website has some good ways to uninstall on Mac OSX specifically:​ https://​stackoverflow.com/​questions/​6411909/​how-to-downgrade-jre-jdk-on-mac-osx This website has some good ways to uninstall on Mac OSX specifically:​ https://​stackoverflow.com/​questions/​6411909/​how-to-downgrade-jre-jdk-on-mac-osx
Line 316: Line 316:
  
 [[common_errors|TOP]] [[common_errors|TOP]]
 +
 ---- ----
 +
 ==== <​!DOCTYPE html> ==== ==== <​!DOCTYPE html> ====
  
Line 324: Line 326:
  
   - Stop ProfitTrailer. See [[faq#How do I stop the Bot?]]   - Stop ProfitTrailer. See [[faq#How do I stop the Bot?]]
-  - Edit [[application.properties]] and add this parameter ''​[[application.properties#​logging.level.nl.komtek.pt.services]] = TRACE''​+  - Open application.properties and enter thislogging.level.nl.komtek ​= DEBUG ,or ensure it is not commented out with a hash mark ( # ), then save the file.
   - Delete or rename your ProfitTrailer.log found in the log folder   - Delete or rename your ProfitTrailer.log found in the log folder
   - Start ProfitTrailer   - Start ProfitTrailer
Line 335: Line 337:
  
 [[common_errors|TOP]] [[common_errors|TOP]]
 +
 ---- ----
  
Line 343: Line 346:
   * Bittrex Minimum is: 0.00100000 BTC According to [[https://​support.bittrex.com/​hc/​en-us/​articles/​115003004171-What-are-my-trade-limits-|this article]]   * Bittrex Minimum is: 0.00100000 BTC According to [[https://​support.bittrex.com/​hc/​en-us/​articles/​115003004171-What-are-my-trade-limits-|this article]]
   * Poloniex Minimum is: 0.001 BTC   * Poloniex Minimum is: 0.001 BTC
- 
  
  
 [[common_errors|TOP]] [[common_errors|TOP]]
 +
 ---- ----
  
Line 365: Line 368:
 Date & Time Settings Date & Time Settings
  
- 
----- 
  
 [[common_errors|TOP]] [[common_errors|TOP]]
- 
  
 ---- ----
  
 +====Getting a constant "​Configuration Change Detected"​ message on log or console====
 +Seen in Windows normal: If you are seeing this error, then you can open all your config tabs (PAIRS, DCA, INDICATORS),​ make a simple change (add a space, delete that space somewhere in the file), and save it again. This seems to fix this error. ​
  
- 
-====NONCE ERROR-nonce must be greater than==== 
- 
-**V1 only** 
-There is a required setting ''​connection.nonceLength=17'',​in application.properties that if not present, will generate this error on the Poloniex exchange. Check the setting in the [[application.properties]] wiki page. If property is present, try increasing it by 1 
- 
----- 
 [[common_errors|TOP]] [[common_errors|TOP]]
- 
-====Getting a constant "​Configuration Change Detected"​ message on log or console==== 
-Seen in Windows normal: If you are seeing this error, then you can open all your .properties files (application,​ configuration,​ PAIRS, DCA, INDICATORS),​ make a simple change (add a space, delete that space somewhere in the file), and save it again. This seems to fix this error. ​ 
- 
  
 ---- ----
-\\ 
-[[common_errors|TOP]] 
-\\ 
  
----- 
 ==== Incorrect trailing value for GROW. Value should be between 0 and your exit value. Using DEFAULT instead ==== ==== Incorrect trailing value for GROW. Value should be between 0 and your exit value. Using DEFAULT instead ====
  
 You ''​sell_value''​ and ''​trailing_profit''​ values are equal which means the formula used to calculate the new ''​trailing_profit''​ when using ''​[[pairs.properties#​DEFAULT_trailing_profit_type]]''​ or ''​[[dca.properties#​DEFAULT_DCA_trailing_profit_type]]''​ will not work. The bot has defaulted to using the DEFAULT ''​trailing_profit''​. You ''​sell_value''​ and ''​trailing_profit''​ values are equal which means the formula used to calculate the new ''​trailing_profit''​ when using ''​[[pairs.properties#​DEFAULT_trailing_profit_type]]''​ or ''​[[dca.properties#​DEFAULT_DCA_trailing_profit_type]]''​ will not work. The bot has defaulted to using the DEFAULT ''​trailing_profit''​.
  
-\\ 
 [[common_errors|TOP]] [[common_errors|TOP]]
-\\ 
  
 ~~DISCUSSION~~ ~~DISCUSSION~~
  • common_errors.txt
  • Last modified: 8 days ago
  • by armchairguru