Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
common_errors [2018/09/01 05:39]
sgtbatten
common_errors [2019/01/25 14:02] (current)
armchairguru
Line 23: Line 23:
   * [[common_errors#​error_util_-_error_reading_file_null|ERROR Util - Error reading file null]]   * [[common_errors#​error_util_-_error_reading_file_null|ERROR Util - Error reading file null]]
   * [[common_errors#​profittrailerservice_-_{"​error":"​permission_denied."​}|ProfitTrailerService - {"​error":"​Permission denied."​}]]   * [[common_errors#​profittrailerservice_-_{"​error":"​permission_denied."​}|ProfitTrailerService - {"​error":"​Permission denied."​}]]
-  * [[common_errors#​Binance:​_profittrailerservice_-_occured_in_th,​_result|Binance:​ ProfitTrailerService - Occured in TH, result]] 
   * [[common_errors#​Error:​ -1021, Timestamp for this request is outside of the recvWindow]]   * [[common_errors#​Error:​ -1021, Timestamp for this request is outside of the recvWindow]]
   * [[common_errors#​binance:​_error:​_-1003,​_way_too_many_requests|Binance:​ ERROR: -1003, Way too many requests]]   * [[common_errors#​binance:​_error:​_-1003,​_way_too_many_requests|Binance:​ ERROR: -1003, Way too many requests]]
Line 132: Line 131:
 ====Signature for this request is not valid==== ====Signature for this request is not valid====
  
-This error is normally preceeded by default_api_key ​(default_apiKey for V1.x) or trading_api_key ​(trading_apiKey for V1.x) and indicates that the secret for that API Key is not correct. Check for typos in the key and ensure no extra spaces are at the end.+This error is normally preceeded by default_api_key or trading_api_key and indicates that the secret for that API Key is not correct. Check for typos in the key and ensure no extra spaces are at the end.
  
 [[common_errors|TOP]] [[common_errors|TOP]]
Line 187: Line 186:
         * trading_api<​color #​ed1c24>​_secret</​color>​         * trading_api<​color #​ed1c24>​_secret</​color>​
   - The ''​[[application.properties#​default_api_key]] = '' ​ property is set to an API key that is **not** registered with your ProfitTrailer license.   - The ''​[[application.properties#​default_api_key]] = '' ​ property is set to an API key that is **not** registered with your ProfitTrailer license.
-    - On Discord, message the PT Assistant bot with ''​/listkeys''​ and verify that your API key is properly registered. If not, you will need to add the api key that you are attempting to use. (See: [[pt_assistant|API Key Guide]])+    - On Discord, message the PT Assistant bot with ''​!listkeys''​ and verify that your API key is properly registered. If not, you will need to add the api key that you are attempting to use. (See: [[pt_assistant|API Key Guide]])
   - There is a space after the ''​license''​ or ''​api_key''​. (e.g license = '​abcdefg ')   - There is a space after the ''​license''​ or ''​api_key''​. (e.g license = '​abcdefg ')
   - Unable to communicate with the ProfitTrailer licensing servers   - Unable to communicate with the ProfitTrailer licensing servers
Line 194: Line 193:
  - Some Antivirus/​Firewall software can block communication needed by the bot. Check to make sure that your Antivirus/​Firewall software is not blocking the bot.  - Some Antivirus/​Firewall software can block communication needed by the bot. Check to make sure that your Antivirus/​Firewall software is not blocking the bot.
   - Incorrect Java version.   - Incorrect Java version.
-    - Ensure that Java 8 is the only version of java installed on your system. If java 9, 10, 11+ etc. are also installed, you can run into this issue even if you know for sure that it is "​only"​ using java 8. (i.e. even if java -version shows java 8, you are not safe if you have other versions installed). On Ubuntu here is how you can nuke them all and start with java 8 from scratch: https://​askubuntu.com/​questions/​84483/​how-to-completely-uninstall-java+    - Ensure that Java 8 is the only version of java installed on your system. If java 9, 10, 11+ etc. are also installed, you can run into this issue even if you know for sure that it is "​only"​ using java 8. (i.e. even if java -version shows java 8, you are not safe if you have other versions installed). On Ubuntu here is how you can remove ​them all and start with java 8 from scratch: https://​askubuntu.com/​questions/​84483/​how-to-completely-uninstall-java
  
  
Line 203: Line 202:
  
 There are a number of issues that can cause this error. There are a number of issues that can cause this error.
 +
 +==NOTE: If you receive this error when starting a V1 bot, you will need to upgrade your installation. V1 bots will no longer work.==
  
 1. New users often experience this error when running the bot for the first time: 1. New users often experience this error when running the bot for the first time:
Line 212: Line 213:
  
 3. If your bot has been working and suddenly you receive this error without having edited anything relating to your application.properties file it may be due to any of the following: 3. If your bot has been working and suddenly you receive this error without having edited anything relating to your application.properties file it may be due to any of the following:
-  * Sometimes your license key just gets invalidated. New API Keys may fix it. Dont forget to register the new default:​[[https://​wiki.profittrailer.io/doku.php/faq#registering_api_keys_for_pt|Follow this guide]]+  * Sometimes your license key just gets invalidated. New API Keys may fix it. Don'​t ​forget to register the new default:​[[https://​wiki.profittrailer.com/doku.php?​id=pt_assistant#registering_api_keys_with_pt_assistant_bot|Follow this guide]]
   * It may be due to slow or broken internet access, a reboot of the machine may fix it.    * It may be due to slow or broken internet access, a reboot of the machine may fix it. 
-  * Latency between your bot and our licence ​server. Give it some time. If the error persists, take action! +  * Latency between your bot and our license ​server. Give it some time. If the error persists, take action! 
-  * Our licence ​server might have an issue. See if other users are also experiencing this.+  * Our license ​server might have an issue. See if other users are also experiencing this.
  
  
Line 227: Line 228:
 ====Invalid API-Key, IP, or Permissions==== ====Invalid API-Key, IP, or Permissions====
  
-Please fix: trading_api_key ​(trading_apiKey for V1.x) -- ERROR: -2015, Invalid API-key, IP, or permissions for action.\\ +Please fix: trading_api_key -- ERROR: -2015, Invalid API-key, IP, or permissions for action.\\ 
-Please fix: default_api_key ​(default_apiKey for V1.x) -- ERROR: -2015, Invalid API-key, IP, or permissions for action.+Please fix: default_api_key -- ERROR: -2015, Invalid API-key, IP, or permissions for action.
  
  
Line 286: Line 287:
 ---- ----
  
-====Binance:​ ProfitTrailerService - Occured in TH, result ==== 
- 
-Full error message : 
-<file java>​ProfitTrailerService - Occured in TH, result: Market Symbol should be  
-ending with BTC, ETH or USDT. Example: BQXBTC</​file>​ 
- 
-This error will appear if you have setup up consecutive ​buy/sell triggers ​in the PAIRS.properties ​file. ​ 
-This is not yet supported on Binance, ​so disable the triggers by setting them to 0. 
- 
- 
-[[common_errors|TOP]] 
----- 
  
 ====Error: -1021, Timestamp for this request is outside of the recvWindow==== ====Error: -1021, Timestamp for this request is outside of the recvWindow====
Line 350: Line 339:
 If you get the above error, you need to install the proper version of the JAVA JDK. Version 9 is not supported, you will need to revert back to version 8. You will need to uninstall the current version first. If you get the above error, you need to install the proper version of the JAVA JDK. Version 9 is not supported, you will need to revert back to version 8. You will need to uninstall the current version first.
  
-This webpage contains the proper version: ​http://​www.oracle.com/​technetwork/​java/​javase/​downloads/​jdk8-downloads-2133151.html+This webpage contains the proper version: ​https://​www.oracle.com/​technetwork/​java/​javase/​downloads/​jdk8-downloads-2133151.html
  
 This website has some good ways to uninstall on Mac OSX specifically:​ https://​stackoverflow.com/​questions/​6411909/​how-to-downgrade-jre-jdk-on-mac-osx This website has some good ways to uninstall on Mac OSX specifically:​ https://​stackoverflow.com/​questions/​6411909/​how-to-downgrade-jre-jdk-on-mac-osx
  • common_errors.1535780362.txt.gz
  • Last modified: 6 months ago
  • by sgtbatten