Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
common_errors [2019/04/12 16:40]
armchairguru
common_errors [2019/05/28 01:19] (current)
armchairguru
Line 1: Line 1:
- 
 ==== Common Error Messages ==== ==== Common Error Messages ====
-----+
 PTTracker Common Errors => [[https://​github.com/​bTayFla/​PtTracker/​wiki/​Troubleshooting|Click Here!]] PTTracker Common Errors => [[https://​github.com/​bTayFla/​PtTracker/​wiki/​Troubleshooting|Click Here!]]
  
 +----
  
 __The best way to use this page is to use the Search feature at the top to search for keywords in your error.__ __The best way to use this page is to use the Search feature at the top to search for keywords in your error.__
Line 22: Line 22:
   * [[common_errors#​profittrailerservice_-_{"​error":"​permission_denied."​}|ProfitTrailerService - {"​error":"​Permission denied."​}]]   * [[common_errors#​profittrailerservice_-_{"​error":"​permission_denied."​}|ProfitTrailerService - {"​error":"​Permission denied."​}]]
   * [[common_errors#​Error:​ -1021, Timestamp for this request is outside of the recvWindow]]   * [[common_errors#​Error:​ -1021, Timestamp for this request is outside of the recvWindow]]
 +  * [[common_errors#​Error:​ -1022, SIGNATURE FOR THIS REQUEST IS NOT VALID]]
   * [[common_errors#​binance:​_error:​_-1003,​_way_too_many_requests|Binance:​ ERROR: -1003, Way too many requests]]   * [[common_errors#​binance:​_error:​_-1003,​_way_too_many_requests|Binance:​ ERROR: -1003, Way too many requests]]
   * [[common_errors#​error_application_-_please_install_java_8|ERROR Application - Please install JAVA 8]]   * [[common_errors#​error_application_-_please_install_java_8|ERROR Application - Please install JAVA 8]]
Line 40: Line 41:
 If you are indeed running the up-to-date cmd file the issue is that UAC and SmartScreen are enabled, and the newly downloaded zip file (or cmd file) is "​blocked",​ due to being flagged as having come from an Internet zone. If you are indeed running the up-to-date cmd file the issue is that UAC and SmartScreen are enabled, and the newly downloaded zip file (or cmd file) is "​blocked",​ due to being flagged as having come from an Internet zone.
  
-Couple of possible ways to fix this: \\ +Couple of possible ways to fix this:\\ 
-1) Right-click the zip file (or the cmd file if you already extracted it), Properties, click Unblock.+{{unblock-dialog.png?​nolink&​400}}\\ 
 +1) Right-click the zip file (or the cmd file if you already extracted it), Properties, click or uncheck ​Unblock; it may be a checkbox or a button.
 https://​blogs.msdn.microsoft.com/​delay/​p/​unblockingdownloadedfile/​ https://​blogs.msdn.microsoft.com/​delay/​p/​unblockingdownloadedfile/​
  
Line 113: Line 115:
 ====Please Set a Gain==== ====Please Set a Gain====
  
-If you happen to see this then you may need to set either a [[pairs.properties#​default_a_sell_value|GAIN]] value or a [[pairs.properties#​default_pending_gain_percentage|PENDING_GAIN]] value in your Pairs or DCA configs.+If you happen to see this then you may need to set either a [[pairs_config#​default_a_sell_value|GAIN]] value or a [[pairs_config#​default_pending_gain_percentage|PENDING_GAIN]] value in your Pairs or DCA configs.
  
 [[common_errors|TOP]] [[common_errors|TOP]]
Line 137: Line 139:
 ====Binance does not support this period==== ====Binance does not support this period====
  
-In the [[indicators.properties|Indicators Config]] you can only set periods that exist on the exchange. Check your exchange or see [[Exchanges]] for compatible periods.+In the [[indicators_config|Indicators Config]] you can only set periods that exist on the exchange. Check your exchange or see [[Exchanges]] for compatible periods.
  
 [[common_errors|TOP]] [[common_errors|TOP]]
Line 161: Line 163:
 There are multiple things that can cause this error, but most commonly this is caused by misconfiguration of the application.properties file or your API Key not being properly registered on your ProfitTrailer license. Below are the most common causes of this error: There are multiple things that can cause this error, but most commonly this is caused by misconfiguration of the application.properties file or your API Key not being properly registered on your ProfitTrailer license. Below are the most common causes of this error:
   - The ''​[[application.properties#​license]] = ''​ property is missing or set incorrectly (This property didn't exist in v1, but is required for v2)   - The ''​[[application.properties#​license]] = ''​ property is missing or set incorrectly (This property didn't exist in v1, but is required for v2)
-    - In the application.properties file, please ensure that you have the ''​[[application.properties#​license]]''​ parameter set to your ProfitTrailer License number for the proper ​exchage, and NOT an API key. (Your ProfitTrailer License would have been emailed to you when you purchased the bot. Email subject "​ProfitTrailer license activation!"​)+    - In the application.properties file, please ensure that you have the ''​[[application.properties#​license]]''​ parameter set to your ProfitTrailer License number for the proper ​exchange, and NOT an API key. (Your ProfitTrailer License would have been emailed to you when you purchased the bot. Email subject "​ProfitTrailer license activation!"​)
     - Make sure that you are using the correct license for the Exchange that you are trying to run. (if you are using a multi-exchange license, then the license number is the same)     - Make sure that you are using the correct license for the Exchange that you are trying to run. (if you are using a multi-exchange license, then the license number is the same)
     - If you purchased the bot for multiple exchanges and have a legacy license (before multi-exchange),​ each exchange will have their own unique ProfitTrailer license number.     - If you purchased the bot for multiple exchanges and have a legacy license (before multi-exchange),​ each exchange will have their own unique ProfitTrailer license number.
Line 185: Line 187:
   - Incorrect Java version.   - Incorrect Java version.
     - Ensure that Java 8 is the only version of java installed on your system. If java 9, 10, 11+ etc. are also installed, you can run into this issue even if you know for sure that it is "​only"​ using java 8. (i.e. even if java -version shows java 8, you are not safe if you have other versions installed). On Ubuntu here is how you can remove them all and start with java 8 from scratch: https://​askubuntu.com/​questions/​84483/​how-to-completely-uninstall-java     - Ensure that Java 8 is the only version of java installed on your system. If java 9, 10, 11+ etc. are also installed, you can run into this issue even if you know for sure that it is "​only"​ using java 8. (i.e. even if java -version shows java 8, you are not safe if you have other versions installed). On Ubuntu here is how you can remove them all and start with java 8 from scratch: https://​askubuntu.com/​questions/​84483/​how-to-completely-uninstall-java
 +  - Incorrect bot version.
 +    - If you are running an older version of ProfitTrailer,​ it may display this message. You will need to update.
  
  
Line 283: Line 287:
 Go to System Preferences,​ click Date & Time, and ensure the check box is checked for “Set Date and Time Automatically”. Select your time zone and a server that is close to your location if possible. Go to System Preferences,​ click Date & Time, and ensure the check box is checked for “Set Date and Time Automatically”. Select your time zone and a server that is close to your location if possible.
  
 +
 +[[common_errors|TOP]]
 +
 +----
 +
 +====Error: -1022, SIGNATURE FOR THIS REQUEST IS NOT VALID====
 +
 +Your [[application.properties#​default_api_secret| Default API Secret]] key is incorrect and needs to be corrected / changed.\\
 +It may not match the Default API Key or may be pasted incorrectly.
 +
 +As most API secrets are not shown more than once at creation time, you may need to make another API Key to gain access to a correct matching API secret.
  
 [[common_errors|TOP]] [[common_errors|TOP]]
Line 341: Line 356:
  
 ====ERROR: -1013, Filter failure: MIN_NOTIONAL==== ====ERROR: -1013, Filter failure: MIN_NOTIONAL====
-You are trading with amounts less than the minimum trade size for your exchange. You need to increase your DEFAULT_initial_cost,​ or increase your DEFAULT_initial_cost_percentage. Also check you have appropriate [[pairs.properties#dust settings]] if used.+You are trading with amounts less than the minimum trade size for your exchange. You need to increase your DEFAULT_initial_cost,​ or increase your DEFAULT_initial_cost_percentage. Also check you have appropriate [[pairs_config#dust settings]] if used.
  
   * Binance has their minimums listed here: https://​support.binance.com/​hc/​en-us/​articles/​115000594711-Trading-Rule   * Binance has their minimums listed here: https://​support.binance.com/​hc/​en-us/​articles/​115000594711-Trading-Rule
Line 382: Line 397:
 ==== Incorrect trailing value for GROW. Value should be between 0 and your exit value. Using DEFAULT instead ==== ==== Incorrect trailing value for GROW. Value should be between 0 and your exit value. Using DEFAULT instead ====
  
-You ''​sell_value''​ and ''​trailing_profit''​ values are equal which means the formula used to calculate the new ''​trailing_profit''​ when using ''​[[pairs.properties#​DEFAULT_trailing_profit_type]]''​ or ''​[[dca.properties#​DEFAULT_DCA_trailing_profit_type]]''​ will not work. The bot has defaulted to using the DEFAULT ''​trailing_profit''​.+You ''​sell_value''​ and ''​trailing_profit''​ values are equal which means the formula used to calculate the new ''​trailing_profit''​ when using ''​[[pairs_config#​DEFAULT_trailing_profit_type]]''​ or ''​[[dca_config#​DEFAULT_DCA_trailing_profit_type]]''​ will not work. The bot has defaulted to using the DEFAULT ''​trailing_profit''​.
  
 [[common_errors|TOP]] [[common_errors|TOP]]
- 
-~~DISCUSSION~~ 
  • common_errors.1555087252.txt.gz
  • Last modified: 2 months ago
  • by armchairguru