Häufig auftretende Fehler Meldungen

ERROR Application - INVALID LICENSE

Dies ist ein bekannter aber auch für uns ein komischer Fehler, denn normalerweise sollte dieser nicht auftreten wenn man alle Schritte der Installation befolgt hat.

Manchmal liegt es auch an deiner Internet Verbindung weil der Bot eine Verbindung zum Lizenzserver aufbaut beim start. Wenn hier die Verbindung abbricht oder nicht aufgebaut werden kann, reicht ein einfaches “abwarten” und später nochmal probieren, aus. Auch ein REBOOT deines PC / VPS hilft teilweise.

Beachte bitte auch das wenn du F2A in deinem Exchange ausstellst, veränderst, aktivierst oder neu machst, deine API KEYS ungültig werden. Dann folge bitte direkt den Anweisungen unten:

Sollte der Bot auch nach einer Zeit von 1 Stunde diesen Fehler anzeigen obwohl du nicht verändert hast, folge bitte den Anweisungen:

Die wirksamste Methode ist es, einen neuen Api Key zu erstellen und diesen dann per Telegram Assistant neu zu registriern.

  1. Gehe zu deinem Exchange und erstelle einen neuen Key (inklusive deinem Secret Key).
  2. Öffne einen Telegram Chat mit dem PT Assistant Bot.https://t.me/ProfitTrailerAssistantBot
  3. Schreibe /addKey
  4. Der Assistant fragt dich nach deiner Lizenznummer, die du bei der Bestellung bzw. Aktivierung per eMail von uns erhalten hast. Gebe diese Lizenznummer bitte ein.
  5. Bei erfolgter Eingabe deiner Lizenznummer, bittet der Assistant um Eingabe des neuen Api Key und fragt anschließend nochmal ab ob der Key auch richtig ist und quitiert dies mit der Antwort das dein Api Key aktiviert wurde.
  6. Nun musst du noch deinen neuen API Key inklusive dem dazugehörigem Secret Key in der Datei configuration.properties ändern und den Bot neu starten.

Das Problem sollte jetzt behoben sein.

Mit /removekey kannst du übrigens deinen “alten” Api Key über den Assistanten löschen.

So wie auf dem Bild sieht eine erfolgreiche Koversation mit dem Assistent Bot aus: 

TOP

Error occured in buy...NOT_SUPPORTED

Dieser Fehler ist das Ergebnis von ​sell_fillOrKill = true​ Einstellungen in Binance oder Bittrex, welche von beiden Exchanges nicht unterstützt werden. Setze bitte den Wert auf false.

TOP —-

StringIndexOutOfBoundsException:​ String index out of range: -10

Der Fehler tritt bei Bittrex auf, wenn du IP Filter einsetzt, aber deine VPS / Home IP dort nicht eingetragen ist. TOP


ERROR Util - Error reading file null

Hinweis Dieser Fehler sollte mit der Version 1.2.6.9 nicht mehr auftreten, da dieser gefixt ist und auch nicht bei einem unerwartetem schließen der CMD File oder wenn der Bot nicht ordentlich beendet wird, auftreten sollte. Es wird automatisch eine Backup Datei erstellt. Solltest du diesen Fehler erhalten, aktualisiere bitte deine PT Version.

Full error message:

ERROR Util - Error reading file null

or

Error reading file java.lang.illegalstateException: Expected 
BIGIN-OBJECT but was STRING at line 1 column 1 path $ou ERROR ProfitTrailerService - Handled exception com.google.gson.stream.MalformedJsonException: Use JsonReader.setLenient(true) to accept 
malformed JSON at line 2 column 2 path $

Dieser Fehler wird angezeigt wenn die Datei ProfitTrailerData.json ​beschädigt ist, dies passiert meist wenn der PT Bot nicht ordnungsgemäß ausgeschaltet wird. (Durch schließen der CMD, oder PC/Server Reboot)

In dem PT Ordner ist eine Datei mit Namen ProfitTrailerData.json.backup. Gehe wie folgt vor:

  • Stoppe den ProfitTrailer (localhost:8081/stop) Mehr Infos: hier
  • Lösche die Datei ProfitTrailerData.json ​und nenne die Datei ProfitTailerData.json.backup nach ProfitTrailerData.json um
  • Starte den ProfitTrailer ​wieder

TOP


ProfitTrailerService - {"error":"Permission denied."}

Permission denied resultiert daraus, das du deinen Api Keys im Exchange keine Rechte gegeben hast. Bitte darauf achten das mit den Api Keys alles, bis auf Withdraw (Auszahlung) möglich sein muss.

Bitte achte auch auf deine IP Listen, wenn du diese verwendest dann kontrolliere ob diese auch übereinstimmen.

TOP


Binance: ProfitTrailerService - Occured in TH, result

Komplette Fehlermeldung :

ProfitTrailerService - Occured in TH, result: Market Symbol should be 
ending with BTC, ETH or USDT. Example: BQXBTC

Dieser Fehler erscheint wenn du beim Exchange Binance in der Datei Pairs die Werte für consecutive ​buy/sell triggers gesetzt hast.

Bitte setze für BINANCE den Wert auf 0

  1. ALL_consecutive_buy_trigger = 0
  2. ALL_consecutive_sell_trigger = 0

TOP


Binance: Error Application - Please fix: trading_apikey

Komplette Fehlermeldung:

Error Application - Please fix: trading_apikey — Error: -1021, Timestamp for this 
request is outside of the recvwindow

Lösung: Syncronisiere deine Computer / Server / VPS Zeit mit dem Internet.

TOP


Binance: ERROR: -1003, Way too many requests

Komplette Fehlermeldung:

ERROR AllScheduledTasks - 
nl.komtek.pt.utils.PTHandledErrorException: 
ERROR: -1003, Way too many requests; 
IP banned until 1512488458967.

Verschiedene Provider haben gesperrte IP Adressen, unter anderem ​Vultr (Japan Data Center) & Amazon EC2 (Japan, Korea) - Hier musst du dann leider den Provider wechseln.

TOP


ERROR Application - Please install java 8

Wenn du diesen Fehler bekommst, musst du deine JAVA JDK updaten. Version 9 wird nicht unterstützt, falls du dies installiert hast, musst du zurückrüsten auf Version 8. Dazu muss Java 9 zuerst deinstalliert werden.

Hier findest du die aktuell richtige und unterstützte Version: http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html

Hier ein Tutorial wie man Java 9 deinstalliert und auf Java 8 downgraded.: https://stackoverflow.com/questions/6411909/how-to-downgrade-jre-jdk-on-mac-osx

TOP


ERROR: -1013, Filter failure: MIN_NOTIONAL

Dein Tradinglimit in ALL_max_cost oder ALL_max_cost_percentage ist zu niedrig. Diese sind pro Exchange unterschiedlich. Erhöhe den Wert entsprechend dem Mindestwert deines Exchanges und stelle sicher das du deine Dust Level Settings in der configuration.properties Datei eingestellt hast.

Mehr zum Dust: those here.

Hier kannst du nachlesen welche Minimum Einstellungen die Exchanges verlangen:

TOP


ERROR: Timestamp for this request was 1000ms ahead of the server's time

Die Uhrzeit auf dem von dir genutzen Server / VPS / Laptop / PC oder sonstigem Gerät ist nicht mit der Uhrzeit des PT Bot syncron. Bitte nutze Programme die deine Uhrzeit mit dem Internet syncronisieren.


TOP

====NONCE ERROR-nonce must be greater than====

Dies ist eine vorgeschriebene Einstellung = ​connection.nonceLength=17,​in application.properties - wenn diese fehlt, kommt es zur Fehlermeldung bei Poloniex Accounts. Schaue auch in die application.properties Wiki Seite.

—- TOP

Getting a constant "​Configuration Change Detected"​ message on log or console

Wenn du diesen Fehler bekommst, öffne einfach die application.properties file, mach irgendwo ein Leerzeichen oder Zeichen hin, speicher die Datei, öffne sie nochmal und entferne das Zeichen und speichere wieder. Dies sollte den Fehler beheben.

—- TOP

  • de/common_errors.txt
  • Last modified: 14 months ago
  • by t1m3c